ucl: Use -std=iso9899:1990 instead of -std=c90
authorAlexey Neyman <stilor@att.net>
Wed, 25 Jan 2017 19:20:20 +0000 (11:20 -0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 26 Jan 2017 07:58:41 +0000 (20:58 +1300)
The shorter alias, -std=c90, is not known by older versions of GCC.
See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=20631.

Signed-off-by: Alexey Neyman <stilor@att.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ucl/ucl.mk

index e4dc1b3eda2f92a81e458fec1080a1791016020d..b183a13b26b68dcba2a1a8c07c6250f1b13e5fa6 100644 (file)
@@ -10,6 +10,6 @@ UCL_LICENSE = GPLv2+
 UCL_LICENSE_FILES = COPYING
 
 # Fix ACC conformance test failure for host gcc 6.x
-HOST_UCL_CONF_ENV += CPPFLAGS="$(HOST_CPPFLAGS) -std=c90"
+HOST_UCL_CONF_ENV += CPPFLAGS="$(HOST_CPPFLAGS) -std=iso9899:1990"
 
 $(eval $(host-autotools-package))