package/nvidia-driver: install an egl.pc
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 29 Aug 2017 20:49:59 +0000 (22:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Aug 2017 20:58:05 +0000 (22:58 +0200)
A lot of packages expect an egl.pc to decide that EGL is available. So,
provide one.

As suggested by Alexandre, use the one from nvidia-tegra23 as template.

Reported-by: Alexandre Maumené <alexandre@maumene.org>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Alexandre Maumené <alexandre@maumene.org>
Cc: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nvidia-driver/egl.pc [new file with mode: 0644]
package/nvidia-driver/nvidia-driver.mk

diff --git a/package/nvidia-driver/egl.pc b/package/nvidia-driver/egl.pc
new file mode 100644 (file)
index 0000000..a5aeace
--- /dev/null
@@ -0,0 +1,10 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: egl
+Description: Nvidia OpenGL library
+Version: 1
+Cflags: -I${includedir}
+Libs: -L${libdir} -lEGL
index d8dedd9e3be4e60c7606f6db3fe0b43a7e36cf0b..6746134a52e1d485176173a834267a5ae7a6f99d 100644 (file)
@@ -78,6 +78,7 @@ define NVIDIA_DRIVER_INSTALL_GL_DEV
        $(SED) 's:__LIBGL_PATH__:/usr/lib:' $(STAGING_DIR)/usr/lib/libGL.la
        $(SED) 's:-L[^[:space:]]\+::' $(STAGING_DIR)/usr/lib/libGL.la
        $(INSTALL) -D -m 0644 package/nvidia-driver/gl.pc $(STAGING_DIR)/usr/lib/pkgconfig/gl.pc
+       $(INSTALL) -D -m 0644 package/nvidia-driver/egl.pc $(STAGING_DIR)/usr/lib/pkgconfig/egl.pc
 endef
 
 # Those libraries are 'private' libraries requiring an agreement with