newt: cleanup patches
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Jan 2015 10:58:36 +0000 (11:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Jan 2015 10:58:36 +0000 (11:58 +0100)
This commit slightly cleans up the newt patches: use Git formatted
patches, improve title and description. This was done in preparation
for the upstream submission of those patches.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/newt/0001-Use-CC-instead-of-CPP-to-generate-.depend-files.patch [new file with mode: 0644]
package/newt/0001-newt-fix-makefile.patch [deleted file]
package/newt/0002-Remove-bogus-I-usr-include-slang-from-CPPFLAGS.patch [new file with mode: 0644]
package/newt/0002-slang-include-dir.patch [deleted file]

diff --git a/package/newt/0001-Use-CC-instead-of-CPP-to-generate-.depend-files.patch b/package/newt/0001-Use-CC-instead-of-CPP-to-generate-.depend-files.patch
new file mode 100644 (file)
index 0000000..853472b
--- /dev/null
@@ -0,0 +1,38 @@
+From 65754effe16506a7a0a04069c8b6e1281811604d Mon Sep 17 00:00:00 2001
+From: Samuel Martin <s.martin49@gmail.com>
+Date: Sat, 10 Jan 2015 11:54:10 +0100
+Subject: [PATCH newt 1/2] Use $(CC) instead of $(CPP) to generate .depend
+ files
+
+Use $(CC) instead of $(CPP) to generate .depend file because '$(CPP)
+-M' call does not support multiple input files.  This avoid the
+following error:
+
+make[1]: Entering directory `/opt/br/output/build/newt-0.51.0'
+/opt/br/output/host/usr/bin/arm-none-linux-gnueabi-cpp -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -M newt.c button.c form.c checkbox.c entry.c label.c listbox.c scrollbar.c textbox.c scale.c grid.c windows.c buttonbar.c checkboxtree.c > .depend
+arm-none-linux-gnueabi-cpp: too many input files
+make[1]: *** [depend] Error 1
+
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
+Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 7989203..17853e0 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -121,7 +121,7 @@ clean:
+               $(SHAREDDIR)/*.o *.$(SOEXT)*
+ depend:
+-      $(CPP) $(CFLAGS) $(CPPFLAGS) -M $(SOURCES) > .depend
++      $(CC) $(CFLAGS) $(CPPFLAGS) -M $(SOURCES) > .depend
+ $(SHAREDDIR):
+       mkdir -p $(SHAREDDIR)
+-- 
+2.1.0
+
diff --git a/package/newt/0001-newt-fix-makefile.patch b/package/newt/0001-newt-fix-makefile.patch
deleted file mode 100644 (file)
index 84152fb..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-Fix Makefile.in
-
-* Use $(CC) instead of $(CPP) to generate .depend file because
-  '$(CPP) -M' call does not support multiple input files.
-  This avoid the following error:
-
-make[1]: Entering directory `/opt/br/output/build/newt-0.51.0'
-/opt/br/output/host/usr/bin/arm-none-linux-gnueabi-cpp -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -M newt.c button.c form.c checkbox.c entry.c label.c listbox.c scrollbar.c textbox.c scale.c grid.c windows.c buttonbar.c checkboxtree.c > .depend
-arm-none-linux-gnueabi-cpp: too many input files
-make[1]: *** [depend] Error 1
-make[1]: Leaving directory 
-`/opt/br/output/build/newt-0.51.0'
-make: *** 
-[/opt/br/output/build/newt-0.51.0/.stamp_built] Error 2
-
-Signed-off-by: Samuel Martin <s.martin49@gmail.com>
-Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
-
----
- Makefile.in |    2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-Index: b/Makefile.in
-===================================================================
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -121,7 +121,7 @@
-               $(SHAREDDIR)/*.o *.$(SOEXT)*
- depend:
--      $(CPP) $(CFLAGS) $(CPPFLAGS) -M $(SOURCES) > .depend
-+      $(CC) $(CFLAGS) $(CPPFLAGS) -M $(SOURCES) > .depend
- $(SHAREDDIR):
-       mkdir -p $(SHAREDDIR)
diff --git a/package/newt/0002-Remove-bogus-I-usr-include-slang-from-CPPFLAGS.patch b/package/newt/0002-Remove-bogus-I-usr-include-slang-from-CPPFLAGS.patch
new file mode 100644 (file)
index 0000000..eb445dd
--- /dev/null
@@ -0,0 +1,33 @@
+From 28145b46649165b94666ee585d064b41306e10fd Mon Sep 17 00:00:00 2001
+From: Alex Suykov <alex.suykov@gmail.com>
+Date: Sat, 10 Jan 2015 11:55:32 +0100
+Subject: [PATCH newt 2/2] Remove bogus -I/usr/include/slang from CPPFLAGS
+
+Hardcoding -I/usr/include/slang in CPPFLAGS is bogus for
+cross-compilation. With recent versions of slang, the headers are
+installed in ${sysroot}/usr/include directly, so there is no need for
+an additional flag. And if one was needed, it should be added by the
+configure script, after detecting the right header location.
+
+Signed-off-by: Alex Suykov <alex.suykov@gmail.com>
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 17853e0..d32d784 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -5,7 +5,7 @@ CC = @CC@
+ CPP = @CPP@
+ CFLAGS = @CFLAGS@
+ LDFLAGS = @LDFLAGS@
+-CPPFLAGS = -D_GNU_SOURCE -I/usr/include/slang @CPPFLAGS@ 
++CPPFLAGS = -D_GNU_SOURCE @CPPFLAGS@
+ GNU_LD = @GNU_LD@
+ VERSION = @VERSION@
+-- 
+2.1.0
+
diff --git a/package/newt/0002-slang-include-dir.patch b/package/newt/0002-slang-include-dir.patch
deleted file mode 100644 (file)
index a88ee70..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-slang.h is in sysroot/usr/include, no need to use -I
-
-Signed-off-by: Alex Suykov <alex.suykov@gmail.com>
-
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -5,7 +5,7 @@
- CPP = @CPP@
- CFLAGS = @CFLAGS@
- LDFLAGS = @LDFLAGS@
--CPPFLAGS = -D_GNU_SOURCE -I/usr/include/slang @CPPFLAGS@ 
-+CPPFLAGS = -D_GNU_SOURCE @CPPFLAGS@ 
- GNU_LD = @GNU_LD@
- VERSION = @VERSION@