boot/arm-trusted-firmware: allow additional make targets
authorGervais, Francois <FGervais@distech-controls.com>
Wed, 29 Jan 2020 16:58:23 +0000 (16:58 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 1 Feb 2020 22:15:41 +0000 (23:15 +0100)
Allow specifying additional build targets for ATF.

This might be more useful when using a custom git repository.

For example, when using with the ATF repository from NXP QorIQ,
there is a new build target 'pbl' which is used to build the
pbl binary image. Note that in the specific case of the 'pbl'
target, additional build variables also need to be specified
through BR2_TARGET_ARM_TRUSTED_FIRMWARE_ADDITIONAL_VARIABLES.

Signed-off-by: Francois Gervais <fgervais@distech-controls.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/arm-trusted-firmware/Config.in
boot/arm-trusted-firmware/arm-trusted-firmware.mk

index 96861c3f4d6fe2041044933af4a092724ab37955..373591d4978608a97b9a476c8b4f2b8144d17ec9 100644 (file)
@@ -135,6 +135,13 @@ config BR2_TARGET_ARM_TRUSTED_FIRMWARE_UBOOT_BL33_IMAGE
 
 endif
 
+config BR2_TARGET_ARM_TRUSTED_FIRMWARE_ADDITIONAL_TARGETS
+       string "Additional ATF make targets"
+       help
+         Additional targets for the ATF build
+         E.G. When using the QorIQ custom ATF repository from NXP,
+         the target 'pbl' can be used to build the pbl binary.
+
 config BR2_TARGET_ARM_TRUSTED_FIRMWARE_ADDITIONAL_VARIABLES
        string "Additional ATF build variables"
        help
index 2133d39e6dea126861fc0be6f7e732816e6eb159..bf1ac46cf6c661d2a375cd18cbd5be3779548c71 100644 (file)
@@ -139,6 +139,9 @@ define ARM_TRUSTED_FIRMWARE_BL31_UBOOT_INSTALL_ELF
 endef
 endif
 
+ARM_TRUSTED_FIRMWARE_MAKE_TARGETS += \
+       $(BR2_TARGET_ARM_TRUSTED_FIRMWARE_ADDITIONAL_TARGETS)
+
 define ARM_TRUSTED_FIRMWARE_BUILD_CMDS
        $(ARM_TRUSTED_FIRMWARE_BUILD_FIPTOOL)
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(ARM_TRUSTED_FIRMWARE_MAKE_OPTS) \