package/opkg-utils: remove build step
authorRyan Barnett <ryan.barnett@rockwellcollins.com>
Fri, 12 Mar 2021 20:05:27 +0000 (14:05 -0600)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 13 Mar 2021 07:31:59 +0000 (08:31 +0100)
opkg-utils is a package that only provides bash and python scripts.
Upon further inspection of the Makefile for the package, invoking
`make` only ever builds the manpage. The previous commit dropped the
installation of the manpage. This makes the build step unnecessary so
remove it.

Add a comment to explain the situation

Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
[yann.morin.1998@free.fr: reword commit log]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/opkg-utils/opkg-utils.mk

index be827e6cac28c8afe6793f2ed161101c3bd9721f..a7dc22d7c491c43aeaf9a221799cb6023ced0b80 100644 (file)
@@ -12,10 +12,7 @@ OPKG_UTILS_LICENSE_FILES = COPYING
 
 HOST_OPKG_UTILS_DEPENDENCIES += $(BR2_PYTHON3_HOST_DEPENDENCY)
 
-define HOST_OPKG_UTILS_BUILD_CMDS
-       $(MAKE) -C $(@D) $(HOST_CONFIGURE_OPTS)
-endef
-
+# Nothing to build; only scripts to install.
 define HOST_OPKG_UTILS_INSTALL_CMDS
        $(MAKE) -C $(@D) PREFIX=$(HOST_DIR) install-utils
 endef