package/libblockdev: add support for lvm plugin
authorAdam Duskett <Aduskett@gmail.com>
Sat, 25 Jul 2020 23:06:12 +0000 (16:06 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 29 Aug 2020 19:46:26 +0000 (21:46 +0200)
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libblockdev/Config.in
package/libblockdev/libblockdev.mk

index 9f7f401dd336deffd98029b3c95e708f73bbaff5..732ac410b09a1a361c92c0144a21ece99babdfa1 100644 (file)
@@ -36,6 +36,15 @@ comment "filesystem plugin needs a toolchain w/ locale"
 config BR2_PACKAGE_LIBBLOCKDEV_LOOP
        bool "loop"
 
+config BR2_PACKAGE_LIBBLOCKDEV_LVM2
+       bool "lvm2"
+       depends on BR2_ENABLE_LOCALE # parted
+       select BR2_PACKAGE_PARTED
+       select BR2_PACKAGE_LVM2
+
+comment "lvm2 support needs a toolchain w/ locale"
+       depends on !BR2_ENABLE_LOCALE
+
 endif
 
 comment "libblockdev needs udev /dev management and a toolchain w/ wchar, threads, dynamic library"
index 9216fc9932e2f1af73e3b4a19df0dedfebafb964..b0b0852e8def10271e0513f91bb8ea8ba5815c5d 100644 (file)
@@ -22,7 +22,6 @@ LIBBLOCKDEV_CONF_OPTS = \
        --without-dmraid \
        --without-escrow \
        --without-kbd \
-       --without-lvm \
        --without-lvm_dbus \
        --without-mdraid \
        --without-mpath \
@@ -55,4 +54,11 @@ else
 LIBBLOCKDEV_CONF_OPTS += --without-loop
 endif
 
+ifeq ($(BR2_PACKAGE_LIBBLOCKDEV_LVM2),y)
+LIBBLOCKDEV_DEPENDENCIES += lvm2 parted
+LIBBLOCKDEV_CONF_OPTS += --with-lvm
+else
+LIBBLOCKDEV_CONF_OPTS += --without-lvm
+endif
+
 $(eval $(autotools-package))