setools: update to add sedta and seinfoflow
authorJared Bents <jared.bents@rockwellcollins.com>
Tue, 20 Mar 2018 20:39:43 +0000 (15:39 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 25 Mar 2018 20:41:43 +0000 (22:41 +0200)
Update to add sedta and seinfoflow to setools

Signed-off-by: Jared Bents <jared.bents@rockwellcollins.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/setools/Config.in
package/setools/setools.mk

index ae0c45fe3fd02472a5b03c953d40029e2b850d2d..0a7899b5eb9cd3d0ef65e646347192bb7f3489b3 100644 (file)
@@ -8,6 +8,7 @@ config BR2_PACKAGE_SETOOLS
        depends on BR2_USE_MMU
        select BR2_PACKAGE_PYTHON3 if !BR2_PACKAGE_PYTHON
        select BR2_PACKAGE_PYTHON_ENUM34 if !BR2_PACKAGE_PYTHON3
+       select BR2_PACKAGE_PYTHON_NETWORKX # runtime
        select BR2_PACKAGE_PYTHON_SETUPTOOLS
        select BR2_PACKAGE_LIBSELINUX
        help
@@ -16,6 +17,7 @@ config BR2_PACKAGE_SETOOLS
           * apol - analyze a SELinux policy. (requires python-qt5)
           * sediff - semantic policy difference tool for SELinux.
           * sedta - Perform domain transition analyses
+          * seinfoflow - information flow analysis for SELinux
           * sesearch - Search rules (allow, type_transition, etc.)
 
          https://github.com/TresysTechnology/setools
index 6748c95c23622b34a62a83a4fbaac96b321ace97..1ed7e976d6f0739f003337efdf4792b2e5af5b3f 100644 (file)
@@ -11,7 +11,7 @@ SETOOLS_INSTALL_STAGING = YES
 SETOOLS_LICENSE = GPL-2.0+, LGPL-2.1+
 SETOOLS_LICENSE_FILES = COPYING COPYING.GPL COPYING.LGPL
 SETOOLS_SETUP_TYPE = setuptools
-HOST_SETOOLS_DEPENDENCIES = host-libselinux host-libsepol
+HOST_SETOOLS_DEPENDENCIES = host-libselinux host-libsepol host-python-networkx
 
 ifeq ($(BR2_PACKAGE_PYTHON3),y)
 SETOOLS_PYLIBVER = python$(PYTHON3_VERSION_MAJOR)
@@ -36,14 +36,6 @@ define HOST_SETOOLS_FIX_SETUP
 endef
 HOST_SETOOLS_POST_PATCH_HOOKS += HOST_SETOOLS_FIX_SETUP
 
-# sedta and seinfoflow depend on python-networkx. This package is not
-# available in buildroot.
-define SETOOLS_REMOVE_BROKEN_SCRIPTS
-       $(RM) $(TARGET_DIR)/usr/bin/sedta
-       $(RM) $(TARGET_DIR)/usr/bin/seinfoflow
-endef
-SETOOLS_POST_INSTALL_TARGET_HOOKS += SETOOLS_REMOVE_BROKEN_SCRIPTS
-
 # apol requires pyqt5. However, the setools installation
 # process will install apol even if pyqt5 is missing.
 # Remove these scripts from the target it pyqt5 is not selected.
@@ -55,12 +47,8 @@ endef
 SETOOLS_POST_INSTALL_TARGET_HOOKS += SETOOLS_REMOVE_QT_SCRIPTS
 endif
 
-# sedta and seinfoflow depend on python-networkx. This package is not
-# available in buildroot. pyqt5 is not a host-package, remove apol
-# from the host directory as well.
+# pyqt5 is not a host-package, remove apol from the host directory.
 define HOST_SETOOLS_REMOVE_BROKEN_SCRIPTS
-       $(RM) $(HOST_DIR)/bin/sedta
-       $(RM) $(HOST_DIR)/bin/seinfoflow
        $(RM) $(HOST_DIR)/bin/apol
 endef
 HOST_SETOOLS_POST_INSTALL_HOOKS += HOST_SETOOLS_REMOVE_BROKEN_SCRIPTS