linux: don't automatically set uevent_helper with mdev /dev management
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Fri, 7 Feb 2014 08:20:59 +0000 (09:20 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 9 Feb 2014 21:50:50 +0000 (22:50 +0100)
When mdev /dev management is chosen in the buildroot configuration, the
Linux configuration is updated automatically to set option
CONFIG_UEVENT_HELPER_PATH to "/sbin/mdev". However, the help text of this
option explicitly recommends not setting this option due to large
performance impact during boot (experienced first hand by the reporter ánd
author).

The mdev startup script S10mdev already sets the helper during userspace
boot, which will make sure mdev is working correctly.

Fixes bug #6596: https://bugs.busybox.net/show_bug.cgi?id=6596

Reported-by: Andreas Koop <andreas.koop@zf.com>
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/linux.mk

index 1a81f77c8f58942272eb0c60b93fdbf6364dd4a5..603846740ec704573d130de80f8dce313e43f12e 100644 (file)
@@ -186,8 +186,6 @@ define LINUX_CONFIGURE_CMDS
        $(if $(BR2_ROOTFS_DEVICE_CREATION_STATIC),,
                $(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS,$(@D)/.config)
                $(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS_MOUNT,$(@D)/.config))
-       $(if $(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV),
-               $(call KCONFIG_SET_OPT,CONFIG_UEVENT_HELPER_PATH,\"/sbin/mdev\",$(@D)/.config))
        $(if $(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_UDEV),
                $(call KCONFIG_ENABLE_OPT,CONFIG_INOTIFY_USER,$(@D)/.config))
        $(if $(BR2_PACKAGE_KTAP),