Added configuration item to control whether development headers and libraries are...
authorHamish Moffatt <hamish@cloud.net.au>
Wed, 6 Feb 2008 00:55:05 +0000 (00:55 -0000)
committerHamish Moffatt <hamish@cloud.net.au>
Wed, 6 Feb 2008 00:55:05 +0000 (00:55 -0000)
Removed some additional files if optional modules are disabled

package/python/Config.in
package/python/python.mk

index c209b3e51326bf1754b0cb15a24b0008e6c47301..db09f8ef5557265fe051409d09886008d7cea173 100644 (file)
@@ -6,6 +6,14 @@ config BR2_PACKAGE_PYTHON
 
          http://www.python.org/
 
+config BR2_PACKAGE_PYTHON_DEV
+       depends on BR2_PACKAGE_PYTHON
+       bool "development files on target"
+       default n
+       help
+         If enabled, development files (headers and static libpython) will be
+         installed on the target.
+
 choice
        prompt "Module format to install"
        depends on BR2_PACKAGE_PYTHON
index 9f7e1b885bccf056652857fe21cbba94b7374b2e..050db443fbb1394eeffa59c896e119d307e2b4b4 100644 (file)
@@ -4,6 +4,7 @@
 #
 #############################################################
 PYTHON_VERSION=2.4.2
+PYTHON_VERSION_SHORT=2.4
 PYTHON_SOURCE:=Python-$(PYTHON_VERSION).tar.bz2
 PYTHON_SITE:=http://python.org/ftp/python/$(PYTHON_VERSION)
 PYTHON_DIR:=$(BUILD_DIR)/Python-$(PYTHON_VERSION)
@@ -136,13 +137,31 @@ endif
        find $(TARGET_DIR)/usr/lib/ -name '*.pyo' -exec rm {} \; && \
        rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
                $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc \
-               $(TARGET_DIR)/usr/lib/python*/test
+               $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_SHORT)/test
+       cp -dpr $(TARGET_DIR)/usr/include/python$(PYTHON_VERSION_SHORT) $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib/python$(PYTHON_VERSION_SHORT)
+       cp -dpr $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_SHORT)/config $(STAGING_DIR)/usr/lib/python$(PYTHON_VERSION_SHORT)/
+
 ifeq ($(BR2_PACKAGE_PYTHON_PY_ONLY),y)
        find $(TARGET_DIR)/usr/lib/ -name '*.pyc' -exec rm {} \;
 endif
 ifeq ($(BR2_PACKAGE_PYTHON_PYC_ONLY),y)
        find $(TARGET_DIR)/usr/lib/ -name '*.py' -exec rm {} \;
 endif
+ifneq ($(BR2_PACKAGE_PYTHON_DEV),y)
+       rm -rf $(TARGET_DIR)/usr/include/python$(PYTHON_VERSION_SHORT)
+       rm -rf $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_SHORT)/config
+       find $(TARGET_DIR)/usr/lib/ -name '*.py' -exec rm {} \;
+endif
+ifneq ($(BR2_PACKAGE_PYTHON_BSDDB),y)
+       rm -rf $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_SHORT)/bsddb
+endif
+ifneq ($(BR2_PACKAGE_PYTHON_CURSES),y)
+       rm -rf $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_SHORT)/curses
+endif
+ifneq ($(BR2_PACKAGE_PYTHON_TKINTER),y)
+       rm -rf $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_SHORT)/lib-tk
+endif
 
 python: uclibc $(PYTHON_DEPS) $(TARGET_DIR)/$(PYTHON_TARGET_BINARY)