gnupg: don't bother removing a man page
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:23 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 22:22:34 +0000 (23:22 +0100)
The target-finalize target in the main Makefile removes
$(TARGET_DIR)/usr/share/man entirely, so there's no point in having
some package specific logic to remove man pages.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gnupg/gnupg.mk

index e7c403a71d2eb10a6d0da61205ebd9467fb13417..c0bf88c422bd4560ae03ccfa17fd66373c65b88b 100644 (file)
@@ -39,8 +39,7 @@ endif
 
 ifneq ($(BR2_PACKAGE_GNUPG_GPGV),y)
 define GNUPG_REMOVE_GPGV
-       rm -f $(TARGET_DIR)/usr/bin/gpgv \
-               $(TARGET_DIR)/usr/share/man/man1/gpgv.1
+       rm -f $(TARGET_DIR)/usr/bin/gpgv
 endef
 GNUPG_POST_INSTALL_TARGET_HOOKS += GNUPG_REMOVE_GPGV
 endif