package/omniorb: add optional support for zlib
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 15:18:51 +0000 (16:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 17:28:48 +0000 (18:28 +0100)
When zlib was compiled before, omniorb will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/lib/libomniZIOP4.so.2.0 | grep NEEDED
 0x0000000000000001 (NEEDED)             Shared library: [libomniORB4.so.2]
 0x0000000000000001 (NEEDED)             Shared library: [libomnithread.so.4]
 0x0000000000000001 (NEEDED)             Shared library: [libpthread.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libz.so.1]
[...]

The build system offers no option to en-/disable zlib support,
check acinclude.m4, line 435+.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/omniorb/omniorb.mk

index aaf3bf32228e0191643c108460618571fb8c1fdf..1bbde3b7dc3d2197ad91b45a09cbd5bd8ca0057d 100644 (file)
@@ -30,6 +30,10 @@ HOST_OMNIORB_CONF_OPTS = ac_cv_path_PYTHON=$(HOST_DIR)/usr/bin/python2
 OMNIORB_CONF_OPTS += --disable-longdouble
 HOST_OMNIORB_CONF_OPTS += --disable-longdouble
 
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+OMNIORB_DEPENDENCIES += zlib
+endif
+
 # The EmbeddedSystem define (set below in OMNIORB_ADJUST_TOOLDIR)
 # enables building of just the lib and disables building of
 # tools/apps/services.  In some cases the apps/services are still