mariadb: explicitly disable dtrace detection
authorFrank Hunleth <fhunleth@troodon-software.com>
Mon, 23 Jan 2017 19:47:17 +0000 (14:47 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 23 Jan 2017 21:57:37 +0000 (22:57 +0100)
By default, mariadb's cmake script tries to detect dtrace support. On
hosts that have dtrace installed, this incorrectly enables dtrace and
causes compile errors.

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mariadb/mariadb.mk

index d667208cfaf2dfc8ff7fedb91e2e96f7fb06a064..2e7305ef347e94ca66948fa5cd18e4541571c60b 100644 (file)
@@ -43,6 +43,9 @@ MARIADB_CONF_OPTS += -DWITH_JEMALLOC=no -DWITHOUT_TOKUDB=1
 # Make it explicit that we are cross-compiling
 MARIADB_CONF_OPTS += -DCMAKE_CROSSCOMPILING=1
 
+# Explicitly disable dtrace to avoid detection of a host version
+MARIADB_CONF_OPTS += -DENABLE_DTRACE=0
+
 ifeq ($(BR2_PACKAGE_MARIADB_SERVER),y)
 MARIADB_CONF_OPTS += -DWITH_EMBEDDED_SERVER=ON
 else