package/gconf: enable gobject-introspection support
authorAdam Duskett <Aduskett@gmail.com>
Wed, 1 Apr 2020 00:21:29 +0000 (17:21 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 20:35:25 +0000 (22:35 +0200)
If gobject-introspection is selected, add the gobject-introspection package to
the dependency list and set the conf opt --enable-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gconf/gconf.mk

index 60ced95e18bd7a436338a36c794ec3ffdd69d366..c468d1433c65486696f8a485d7e030a6c0d849cb 100644 (file)
@@ -13,4 +13,11 @@ GCONF_DEPENDENCIES = dbus dbus-glib libglib2 libxml2 \
 GCONF_LICENSE = LGPL-2.0+
 GCONF_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+GCONF_CONF_OPTS += --enable-introspection
+GCONF_DEPENDENCIES += gobject-introspection
+else
+GCONF_CONF_OPTS += --disable-introspection
+endif
+
 $(eval $(autotools-package))