gcc: fix snapshot compile
authorPeter Seiderer <ps.report@gmx.net>
Thu, 20 Mar 2014 22:35:36 +0000 (23:35 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 21 Mar 2014 09:47:05 +0000 (10:47 +0100)
Add gcc snapshot versions dependency on host-flex and host-bison
(done as suggested by Thomas Petazzoni [1]).

Fixes gcc snapshot version 4.9-20140309 compile failure [2].

Tested the following buildroot configs

BR2_arm=y
BR2_cortex_a9=y
BR2_TOOLCHAIN_BUILDROOT_GLIBC=y
BR2_BINUTILS_VERSION_2_24=y
BR2_GCC_VERSION_SNAP=y
BR2_GCC_SNAP_DATE="4.9-20140309"

and

BR2_arcle=y

For the ARC case disabled the BINUTILS_FROM_GIT host-flex and host-bison
dependency.

[1] http://lists.busybox.net/pipermail/buildroot/2014-March/092490.html
[2] http://lists.busybox.net/pipermail/buildroot/2014-March/092459.html

[Peter: simplify logic]
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gcc/gcc.mk

index 236297da531a8d0508a26b84c987ee6f4404ffa2..dff6dce46642882d0e0b9e8bb35ab484683e81d6 100644 (file)
@@ -151,7 +151,7 @@ HOST_GCC_COMMON_DEPENDENCIES += host-mpc
 HOST_GCC_COMMON_CONF_OPT += --with-mpc=$(HOST_DIR)/usr
 endif
 
-ifeq ($(BR2_arc),y)
+ifneq ($(BR2_arc)$(BR2_GCC_VERSION_SNAP),)
 HOST_GCC_COMMON_DEPENDENCIES += host-flex host-bison
 endif