new package: zeromq
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>
Wed, 14 Mar 2012 16:38:16 +0000 (17:38 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 15 Mar 2012 10:42:30 +0000 (11:42 +0100)
[Peter: fix C++/LF deps, reformat help, install into staging]
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/zeromq/Config.in [new file with mode: 0644]
package/zeromq/zeromq.mk [new file with mode: 0644]

index 36a221cfb07e44d72d362ead000fa0e8b39898ff..9eef96e63d0f13a34dba0c4d5a81af4c8485e56f 100644 (file)
@@ -366,6 +366,7 @@ source "package/librsync/Config.in"
 source "package/libsoup/Config.in"
 source "package/libupnp/Config.in"
 source "package/libvncserver/Config.in"
+source "package/zeromq/Config.in"
 endmenu
 
 menu "Other"
diff --git a/package/zeromq/Config.in b/package/zeromq/Config.in
new file mode 100644 (file)
index 0000000..e1d3d52
--- /dev/null
@@ -0,0 +1,25 @@
+comment "zeromq requires a toolchain with C++, LARGEFILE + WCHAR support"
+       depends on !(BR2_INSTALL_LIBSTDCPP &&  BR2_LARGEFILE && BR2_USE_WCHAR)
+
+config BR2_PACKAGE_ZEROMQ
+       bool "zeromq"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_LARGEFILE # util-linux
+       depends on BR2_USE_WCHAR # util-linux
+       select BR2_PACKAGE_UTIL_LINUX
+       select BR2_PACKAGE_UTIL_LINUX_LIBUUID
+       help
+         ØMQ (ZeroMQ, 0MQ, zmq) looks like an embeddable networking
+         library but acts like a concurrency framework. It gives you
+         sockets that carry whole messages across various transports
+         like in-process, inter- process, TCP, and multicast. You can
+         connect sockets N-to-N with patterns like fanout, pub-sub,
+         task distribution, and request-reply.  It's fast enough to
+         be the fabric for clustered products. Its asynchronous I/O
+         model gives you scalable multicore applications, built as
+         asynchronous message-processing tasks. It has a score of
+         language APIs and runs on most operating systems.
+
+         ØMQ is from iMatix and is LGPL open source.
+
+         http://www.zeromq.org/
diff --git a/package/zeromq/zeromq.mk b/package/zeromq/zeromq.mk
new file mode 100644 (file)
index 0000000..b6c499d
--- /dev/null
@@ -0,0 +1,12 @@
+#############################################################
+#
+# zeromq
+#
+#############################################################
+
+ZEROMQ_VERSION = 2.1.11
+ZEROMQ_SITE = http://download.zeromq.org/
+ZEROMQ_INSTALL_STAGING = YES
+ZEROMQ_DEPENDENCIES = util-linux
+
+$(eval $(call AUTOTARGETS))