add new package grantlee
authorZoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Wed, 31 Oct 2012 10:38:03 +0000 (10:38 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 9 Nov 2012 08:56:58 +0000 (09:56 +0100)
[Peter: sort alphabetically in Config.in]
Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/grantlee/Config.in [new file with mode: 0644]
package/grantlee/grantlee.mk [new file with mode: 0644]

index 2ab6b6e681c4f4f96afab552e0f43f65f095a1b3..074e9dfdeb77df23f72585d2b15f0642a5b9263b 100644 (file)
@@ -138,6 +138,7 @@ source "package/qt/Config.in"
 
 if BR2_PACKAGE_QT
 comment "QT libraries and helper libraries"
+source "package/grantlee/Config.in"
 source "package/qextserialport/Config.in"
 source "package/qtuio/Config.in"
 endif
diff --git a/package/grantlee/Config.in b/package/grantlee/Config.in
new file mode 100644 (file)
index 0000000..84afad2
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_GRANTLEE
+       bool "grantlee"
+       select BR2_PACKAGE_QT_STL
+       select BR2_PACKAGE_QT_SCRIPT
+       select BR2_PACKAGE_QT_GUI_MODULE
+       help
+         Qt implemantation of the Django template framework
+
+         http://www.grantlee.org
diff --git a/package/grantlee/grantlee.mk b/package/grantlee/grantlee.mk
new file mode 100644 (file)
index 0000000..10adfd9
--- /dev/null
@@ -0,0 +1,13 @@
+#############################################################
+#
+# grantlee
+#
+#############################################################
+
+GRANTLEE_VERSION = 0.2.0
+GRANTLEE_SITE = http://downloads.grantlee.org
+GRANTLEE_INSTALL_STAGING = YES
+GRANTLEE_DEPENDENCIES =  qt
+
+$(eval $(cmake-package))
+