acpica: new package
authorErico Nunes <nunes.erico@gmail.com>
Sun, 3 Jul 2016 10:45:35 +0000 (12:45 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 5 Jul 2016 08:12:42 +0000 (10:12 +0200)
The ACPI Component Architecture (ACPICA) project provides an operating
system (OS)-independent reference implementation of the Advanced
Configuration and Power Interface Specification (ACPI).

It contains tools such as acpidump, iasl, acpixtract, etc.

Signed-off-by: Erico Nunes <nunes.erico@gmail.com>
Cc: Romain Naour <romain.naour@gmail.com>
Cc: Peter Korsgaard <peter@korsgaard.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
[Thomas: adjust install flags to -m755.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/acpica/Config.in [new file with mode: 0644]
package/acpica/acpica.hash [new file with mode: 0644]
package/acpica/acpica.mk [new file with mode: 0644]

index 2c4c196f64230c28bf278ad1e5da165a24b5d7df..9d20f6ba681849ed7b61a9671bddbff97a6befe0 100644 (file)
@@ -335,6 +335,7 @@ menu "Firmware"
        source "package/zd1211-firmware/Config.in"
 endmenu
        source "package/a10disp/Config.in"
+       source "package/acpica/Config.in"
        source "package/acpid/Config.in"
        source "package/acpitool/Config.in"
        source "package/aer-inject/Config.in"
diff --git a/package/acpica/Config.in b/package/acpica/Config.in
new file mode 100644 (file)
index 0000000..74d1f26
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_ACPICA
+       bool "acpica"
+       help
+         The ACPI Component Architecture (ACPICA) project provides an
+         operating system (OS)-independent reference implementation
+         of the Advanced Configuration and Power Interface
+         Specification (ACPI).
+
+         https://www.acpica.org
diff --git a/package/acpica/acpica.hash b/package/acpica/acpica.hash
new file mode 100644 (file)
index 0000000..8d5257f
--- /dev/null
@@ -0,0 +1,2 @@
+# locally computed hash
+sha256 4ac73a5887b643dcca483f0241cbb808a53326846928edad9a2f86cffcde5850 acpica-unix2-20160527.tar.gz
diff --git a/package/acpica/acpica.mk b/package/acpica/acpica.mk
new file mode 100644 (file)
index 0000000..b8459d8
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# acpica
+#
+################################################################################
+
+ACPICA_VERSION = 20160527
+ACPICA_SOURCE = acpica-unix2-$(ACPICA_VERSION).tar.gz
+ACPICA_SITE = https://acpica.org/sites/acpica/files
+ACPICA_LICENSE = BSD-3c or GPLv2
+ACPICA_LICENSE_FILES = source/include/acpi.h
+ACPICA_DEPENDENCIES = host-bison host-flex
+
+define ACPICA_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               HARDWARE_NAME=$(BR2_ARCH) HOST=_LINUX CC="$(TARGET_CC)" \
+               all
+endef
+
+define ACPICA_INSTALL_TARGET_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               HARDWARE_NAME=$(BR2_ARCH) DESTDIR="$(TARGET_DIR)" \
+               INSTALLFLAGS=-m755 install
+endef
+
+$(eval $(generic-package))