qemu: switch to sdl2
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 30 Oct 2018 08:27:55 +0000 (09:27 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 30 Oct 2018 20:02:51 +0000 (21:02 +0100)
Since version 2.12.0 and
https://github.com/qemu/qemu/commit/e52c6ba34149b4f39c3fd60e59ee32b809db2bfa,
SDL 1.2 is deprecated so switch to SDL 2.0 as SDL 1.2 will be removed in
the last release of 2018

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qemu/Config.in
package/qemu/qemu.mk

index d7390141f9abfe0072f039cb20a50b40eaf41e2d..33d4cccd7b46aa96b8a7bc9cbeaff9b5c122b942 100644 (file)
@@ -118,13 +118,15 @@ comment "Frontends"
 
 config BR2_PACKAGE_QEMU_SDL
        bool "Enable SDL frontend"
-       depends on BR2_PACKAGE_XORG7
-       select BR2_PACKAGE_SDL
-       select BR2_PACKAGE_SDL_X11
+       depends on !BR2_STATIC_LIBS # sdl2
+       select BR2_PACKAGE_SDL2
        help
          Say 'y' to enable the SDL frontend, that is, a graphical
          window presenting the VM's display.
 
+comment "SDL frontend needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
+
 comment "Misc. features"
 
 config BR2_PACKAGE_QEMU_FDT
index 968c8073e47bed92d612ae4649bc9a46564d92bc..5bdf390bc982c600e684ebc7623ef6796cf889a8 100644 (file)
@@ -62,8 +62,8 @@ endif
 
 ifeq ($(BR2_PACKAGE_QEMU_SDL),y)
 QEMU_OPTS += --enable-sdl
-QEMU_DEPENDENCIES += sdl
-QEMU_VARS += SDL_CONFIG=$(BR2_STAGING_DIR)/usr/bin/sdl-config
+QEMU_DEPENDENCIES += sdl2
+QEMU_VARS += SDL2_CONFIG=$(BR2_STAGING_DIR)/usr/bin/sdl2-config
 else
 QEMU_OPTS += --disable-sdl
 endif