tftpd: install TFTP client as well
authorKelvin Cheung <keguang.zhang@gmail.com>
Thu, 23 Oct 2014 11:13:24 +0000 (19:13 +0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Oct 2014 20:11:44 +0000 (22:11 +0200)
This patch installs TFTP client as well and overrides BusyBox
implementations if BusyBox is enabled.

[Thomas: fix typo SYSKLOGD_DEPENDENCIES -> TFTPD_DEPENDENCIES noticed
by Baruch.]

Signed-off-by: Kelvin Cheung <keguang.zhang@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tftpd/tftpd.mk

index c8457db0b4b4a6ffc0071d4fc8926d1684c9a716..816a25ec5160f1c7c78391b818af3921064913a1 100644 (file)
@@ -13,7 +13,13 @@ ifneq ($(BR2_INET_IPV6),y)
 TFTPD_CONF_OPTS += --without-ipv6
 endif
 
+# Override BusyBox implementations if BusyBox is enabled.
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+TFTPD_DEPENDENCIES += busybox
+endif
+
 define TFTPD_INSTALL_TARGET_CMDS
+       $(INSTALL) -D $(@D)/tftp/tftp $(TARGET_DIR)/usr/bin/tftp
        $(INSTALL) -D $(@D)/tftpd/tftpd $(TARGET_DIR)/usr/sbin/tftpd
        $(INSTALL) -D package/tftpd/S80tftpd-hpa $(TARGET_DIR)/etc/init.d/
 endef