mtd: restore installation of libmtd to staging
authorAndrey Yurovsky <yurovsky@gmail.com>
Wed, 28 Jun 2017 03:56:10 +0000 (20:56 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Jul 2017 16:34:07 +0000 (18:34 +0200)
Commit 67117adc891e06154d23a01b8c8ee348c63e78eb backed out the
deployment of libmtd headers (libmtd.h, libubi.h, ubi-media.h) to
staging and these may be needed by packages that work directly with MTD,
for example swupdate. mtd also produces libmtd.a and libubi.a which are
needed by those packages.

Tested by configuring swupdate to use MTD and verifying that swupdate
now compiles and links.

Signed-off-by: Andrey Yurovsky <yurovsky@gmail.com>
[Thomas: change to a post-install staging hook, and add comment.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mtd/mtd.mk

index 3df641ef69a0196a1e29c6ae448676c5faa64ee4..df2e5a3ecd3782c7dfc3be1c624ecb99e13d24f4 100644 (file)
@@ -97,5 +97,17 @@ define MTD_INSTALL_TARGET_CMDS
        )
 endef
 
+# Those libraries are not installed by "make install", but are needed
+# by other packages, such as swupdate.
+define MTD_INSTALL_LIBS
+       $(INSTALL) -D -m 0755 $(@D)/include/libmtd.h $(STAGING_DIR)/usr/include/mtd/libmtd.h
+       $(INSTALL) -D -m 0755 $(@D)/include/libubi.h $(STAGING_DIR)/usr/include/mtd/libubi.h
+       $(INSTALL) -D -m 0755 $(@D)/include/mtd/ubi-media.h $(STAGING_DIR)/usr/include/mtd/ubi-media.h
+       $(INSTALL) -D -m 0755 $(@D)/libmtd.a $(STAGING_DIR)/usr/lib/libmtd.a
+       $(INSTALL) -D -m 0755 $(@D)/libubi.a $(STAGING_DIR)/usr/lib/libubi.a
+endef
+
+MTD_POST_INSTALL_STAGING_HOOKS += MTD_INSTALL_LIBS
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))