lxc: bump to version 1.0.4
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 4 Jul 2014 13:35:31 +0000 (10:35 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 4 Jul 2014 13:38:13 +0000 (15:38 +0200)
Also switch to new homepage and github download, and specify distro
variant since host distro != target distro and sample configs for each
case aren't useful anyway.
It sometimes failed to autodetect because some of the tests can't be
executed when cross compiling (happened on gentoo host).

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/lxc/Config.in
package/lxc/lxc-01-drop-werror.patch [new file with mode: 0644]
package/lxc/lxc.mk

index d0937e6a2f6a5d20e3ee4443c49e2bdbe7f2bf3e..3eae64ac3467801e89ddf12f67614822e9b830b7 100644 (file)
@@ -12,7 +12,7 @@ config BR2_PACKAGE_LXC
          of a set of processes in a jail by virtualizing and accounting the
          kernel resources. It is similar to Linux-Vserver or Openvz.
 
-         http://lxc.sourceforge.net/
+         https://linuxcontainers.org/
 
 comment "lxc needs a toolchain w/ IPv6, threads, largefile"
        depends on BR2_USE_MMU
diff --git a/package/lxc/lxc-01-drop-werror.patch b/package/lxc/lxc-01-drop-werror.patch
new file mode 100644 (file)
index 0000000..d2a8673
--- /dev/null
@@ -0,0 +1,16 @@
+Don't do -Werror it breaks builds on some scenarios with trivialities.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura lxc-lxc-1.0.4/configure.ac lxc-lxc-1.0.4.orig/configure.ac
+--- lxc-lxc-1.0.4.orig/configure.ac    2014-07-04 10:31:19.821029891 -0300
++++ lxc-lxc-1.0.4/configure.ac 2014-06-13 14:07:45.000000000 -0300
+@@ -560,7 +560,7 @@
+ LXC_CHECK_TLS
+ if test "x$GCC" = "xyes"; then
+-      CFLAGS="$CFLAGS -Wall -Werror"
++      CFLAGS="$CFLAGS -Wall"
+ fi
+ # Files requiring some variable expansion
index 4e069029d56d4456f63c2ef613771147d84e97fa..b251b1429f30231e6564e9ec3deb988df625f638 100644 (file)
@@ -4,11 +4,13 @@
 #
 ################################################################################
 
-LXC_VERSION = 0.9.0
-LXC_SITE = http://downloads.sourceforge.net/project/lxc/lxc/lxc-$(LXC_VERSION)
+LXC_VERSION = 1.0.4
+LXC_SITE = $(call github,lxc,lxc,lxc-$(LXC_VERSION))
 LXC_LICENSE = LGPLv2.1+
 LXC_LICENSE_FILES = COPYING
-LXC_DEPENDENCIES = libcap
-LXC_CONF_OPT = --disable-apparmor
+LXC_DEPENDENCIES = libcap host-pkgconf
+# configure not shipped
+LXC_AUTORECONF = YES
+LXC_CONF_OPT = --disable-apparmor --with-distro=buildroot
 
 $(eval $(autotools-package))