fs: ensure hard links in TARGET_DIR are correctly copied for filesystem input
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 27 May 2018 20:48:57 +0000 (22:48 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 27 May 2018 21:46:29 +0000 (23:46 +0200)
Fixes #11046

Commit bb2a57a17a7 (fs: run packages' filesystem hooks in a copy of target/)
changed the file system logic to run file system hooks from packages on a
copy of TARGET_DIR, and finally use this copy as input for the file system
generation.

This copy was done with rsync, which by default does not preserve hard
links, leading to an expansion of the file system images when hard links are
present.

Fix it by passing the -H option to rsync (preserve hard links).

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
fs/common.mk

index 9baf36772927a587ecb1761cc4aa6c40c93e61f2..abf35418cb6926d6e196bda472d19538dfbe7897 100644 (file)
@@ -71,7 +71,7 @@ $(ROOTFS_COMMON_TAR): $(ROOTFS_COMMON_DEPENDENCIES) target-finalize
        @$(call MESSAGE,"Generating common rootfs tarball")
        rm -rf $(FS_DIR)
        mkdir -p $(FS_DIR)
-       rsync -au $(BASE_TARGET_DIR)/ $(TARGET_DIR)
+       rsync -auH $(BASE_TARGET_DIR)/ $(TARGET_DIR)
        echo '#!/bin/sh' > $(FAKEROOT_SCRIPT)
        echo "set -e" >> $(FAKEROOT_SCRIPT)
        echo "chown -h -R 0:0 $(TARGET_DIR)" >> $(FAKEROOT_SCRIPT)