toolchain-external: fix musl-based builds on ARMhf platforms
authorvicencb@gmail.com <vicencb@gmail.com>
Sun, 27 Sep 2015 13:48:22 +0000 (14:48 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 28 Sep 2015 20:41:22 +0000 (22:41 +0200)
When ARCH is arm and the hard-floating-point option is on executables
expect to find the dynamic linker at /lib/ld-musl-armhf.so.1 and not
/lib/ld-musl-arm.so.1.

This patch adjusts the logic that creates the symbolic link from the
dynamic linker path to the musl C library (since musl has everything
built into a single file).

[Thomas: tweak the commit log.]

Signed-off-by: Vicente Bergas <vicencb@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/toolchain-external.mk

index 61a5dba18216fd2f4075c096706d4d64d055c5d8..79afdaab3f0fcddfb4cbd0c83e0c779814920faf 100644 (file)
@@ -524,6 +524,8 @@ endef
 ifeq ($(BR2_TOOLCHAIN_EXTERNAL_MUSL),y)
 ifeq ($(BR2_i386),y)
 MUSL_ARCH = i386
+else ifeq ($(BR2_ARM_EABIHF),y)
+MUSL_ARCH = armhf
 else
 MUSL_ARCH = $(ARCH)
 endif