genext2fs: new package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 1 Mar 2010 22:59:32 +0000 (23:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 9 Apr 2010 09:03:54 +0000 (11:03 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/genext2fs/Config.in [new file with mode: 0644]
package/genext2fs/genext2fs-1.4-nosquash.patch [new file with mode: 0644]
package/genext2fs/genext2fs-1.4-remove_ugly_warnings.patch [new file with mode: 0644]
package/genext2fs/genext2fs.mk [new file with mode: 0644]
target/ext2/genext2fs-1.4-nosquash.patch [deleted file]
target/ext2/genext2fs-1.4-remove_ugly_warnings.patch [deleted file]

index 9c75fcc5e475de35cb52c38a8d964b43bb995f75..856048abd3d6e07ed379a2f61d3ea2c89ad5de20 100644 (file)
@@ -159,6 +159,7 @@ source "package/eeprog/Config.in"
 source "package/fconfig/Config.in"
 source "package/fis/Config.in"
 source "package/gadgetfs-test/Config.in"
+source "package/genext2fs/Config.in"
 source "package/genromfs/Config.in"
 source "package/gvfs/Config.in"
 source "package/hal/Config.in"
diff --git a/package/genext2fs/Config.in b/package/genext2fs/Config.in
new file mode 100644 (file)
index 0000000..82992f8
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_GENEXT2FS
+       bool "genext2fs"
+       help
+         genext2fs generates an ext2 filesystem as a normal (non-root)
+        user.  It does not require you to mount the image file to
+        copy files on it, nor does it require that you become the
+        superuser to make device nodes.
+
+        http://genext2fs.sourceforge.net/
diff --git a/package/genext2fs/genext2fs-1.4-nosquash.patch b/package/genext2fs/genext2fs-1.4-nosquash.patch
new file mode 100644 (file)
index 0000000..236dfcc
--- /dev/null
@@ -0,0 +1,14 @@
+diff -ru genext2fs-1.4/genext2fs.c genext2fs-1.4-nosquash/genext2fs.c
+--- genext2fs-1.4/genext2fs.c  2006-12-19 17:45:31.000000000 +0100
++++ genext2fs-1.4-nosquash/genext2fs.c 2007-02-09 10:47:05.000000000 +0100
+@@ -1629,10 +1629,6 @@
+               mtime = st.st_mtime;
+               name = dent->d_name;
+               mode = get_mode(&st);
+-              if(squash_uids)
+-                      uid = gid = 0;
+-              if(squash_perms)
+-                      mode &= ~(FM_IRWXG | FM_IRWXO);
+               if(stats)
+                       switch(st.st_mode & S_IFMT)
+                       {
diff --git a/package/genext2fs/genext2fs-1.4-remove_ugly_warnings.patch b/package/genext2fs/genext2fs-1.4-remove_ugly_warnings.patch
new file mode 100644 (file)
index 0000000..ef23dfb
--- /dev/null
@@ -0,0 +1,21 @@
+diff -ru genext2fs-1.4/genext2fs.c genext2fs-1.4-remove_ugly_warnings/genext2fs.c
+--- genext2fs-1.4/genext2fs.c  2007-02-09 10:54:56.000000000 +0100
++++ genext2fs-1.4-remove_ugly_warnings/genext2fs.c     2007-02-09 10:54:30.000000000 +0100
+@@ -1606,7 +1606,7 @@
+ static void
+ add2fs_from_dir(filesystem *fs, uint32 this_nod, int squash_uids, int squash_perms, uint32 fs_timestamp, struct stats *stats)
+ {
+-      uint32 nod;
++      uint32 nod = 0;
+       uint32 uid, gid, mode, ctime, mtime;
+       const char *name;
+       FILE *fh;
+@@ -2056,7 +2056,7 @@
+ static filesystem *
+ load_fs(FILE * fh, int swapit)
+ {
+-      size_t fssize;
++      size_t fssize = 0;
+       filesystem *fs;
+       if((fseek(fh, 0, SEEK_END) < 0) || ((ssize_t)(fssize = ftell(fh)) == -1))
+               perror_msg_and_die("input filesystem image");
diff --git a/package/genext2fs/genext2fs.mk b/package/genext2fs/genext2fs.mk
new file mode 100644 (file)
index 0000000..8c4981e
--- /dev/null
@@ -0,0 +1,12 @@
+#############################################################
+#
+# genext2fs
+#
+#############################################################
+
+GENEXT2FS_VERSION=1.4
+GENEXT2FS_SOURCE=genext2fs-$(GENEXT2FS_VERSION).tar.gz
+GENEXT2FS_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/genext2fs
+
+$(eval $(call AUTOTARGETS,package,genext2fs))
+$(eval $(call AUTOTARGETS,package,genext2fs,host))
diff --git a/target/ext2/genext2fs-1.4-nosquash.patch b/target/ext2/genext2fs-1.4-nosquash.patch
deleted file mode 100644 (file)
index 236dfcc..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ru genext2fs-1.4/genext2fs.c genext2fs-1.4-nosquash/genext2fs.c
---- genext2fs-1.4/genext2fs.c  2006-12-19 17:45:31.000000000 +0100
-+++ genext2fs-1.4-nosquash/genext2fs.c 2007-02-09 10:47:05.000000000 +0100
-@@ -1629,10 +1629,6 @@
-               mtime = st.st_mtime;
-               name = dent->d_name;
-               mode = get_mode(&st);
--              if(squash_uids)
--                      uid = gid = 0;
--              if(squash_perms)
--                      mode &= ~(FM_IRWXG | FM_IRWXO);
-               if(stats)
-                       switch(st.st_mode & S_IFMT)
-                       {
diff --git a/target/ext2/genext2fs-1.4-remove_ugly_warnings.patch b/target/ext2/genext2fs-1.4-remove_ugly_warnings.patch
deleted file mode 100644 (file)
index ef23dfb..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ru genext2fs-1.4/genext2fs.c genext2fs-1.4-remove_ugly_warnings/genext2fs.c
---- genext2fs-1.4/genext2fs.c  2007-02-09 10:54:56.000000000 +0100
-+++ genext2fs-1.4-remove_ugly_warnings/genext2fs.c     2007-02-09 10:54:30.000000000 +0100
-@@ -1606,7 +1606,7 @@
- static void
- add2fs_from_dir(filesystem *fs, uint32 this_nod, int squash_uids, int squash_perms, uint32 fs_timestamp, struct stats *stats)
- {
--      uint32 nod;
-+      uint32 nod = 0;
-       uint32 uid, gid, mode, ctime, mtime;
-       const char *name;
-       FILE *fh;
-@@ -2056,7 +2056,7 @@
- static filesystem *
- load_fs(FILE * fh, int swapit)
- {
--      size_t fssize;
-+      size_t fssize = 0;
-       filesystem *fs;
-       if((fseek(fh, 0, SEEK_END) < 0) || ((ssize_t)(fssize = ftell(fh)) == -1))
-               perror_msg_and_die("input filesystem image");