package/vlc: add optional dependency to libdvdread
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:23 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 10:01:05 +0000 (12:01 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index 9e1dc6b92e9155f11ab01430af2c4f09f4430c40..928b3fabb8d38f8e0463a0b6c6b6393d91c2e059 100644 (file)
@@ -206,6 +206,13 @@ else
 VLC_CONF_OPTS += --disable-dvbpsi
 endif
 
+ifeq ($(BR2_PACKAGE_LIBDVDREAD),y)
+VLC_CONF_OPTS += --enable-dvdread
+VLC_DEPENDENCIES += libdvdread
+else
+VLC_CONF_OPTS += --disable-dvdread
+endif
+
 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
 VLC_CONF_OPTS += --enable-libgcrypt
 VLC_DEPENDENCIES += libgcrypt