monit: new package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jun 2012 06:13:51 +0000 (06:13 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 11 Jun 2012 20:29:41 +0000 (22:29 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/monit/Config.in [new file with mode: 0644]
package/monit/monit.mk [new file with mode: 0644]

index 2b69c575c79f90ffe60ebe39d1dd220d82c7f011..2b2c98050d648664006ceab7237138251c9cffa1 100644 (file)
@@ -647,6 +647,9 @@ source "package/htop/Config.in"
 source "package/kmod/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/module-init-tools/Config.in"
+endif
+source "package/monit/Config.in"
+if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/procps/Config.in"
 source "package/psmisc/Config.in"
 source "package/rsyslog/Config.in"
diff --git a/package/monit/Config.in b/package/monit/Config.in
new file mode 100644 (file)
index 0000000..6933aaf
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_MONIT
+       bool "monit"
+       help
+         Monit is a free open source utility for managing and
+         monitoring, processes, programs, files, directories and
+         filesystems on a UNIX system. Monit conducts automatic
+         maintenance and repair and can execute meaningful causal
+         actions in error situations.
+
+         http://mmonit.com/monit/
diff --git a/package/monit/monit.mk b/package/monit/monit.mk
new file mode 100644 (file)
index 0000000..958618d
--- /dev/null
@@ -0,0 +1,30 @@
+#############################################################
+#
+# monit
+#
+#############################################################
+
+MONIT_VERSION = 5.4
+MONIT_SITE = http://mmonit.com/monit/dist/
+
+MONIT_CONF_ENV = \
+       libmonit_cv_setjmp_available=yes \
+       libmonit_cv_vsnprintf_c99_conformant=yes
+
+MONIT_CONF_OPT += \
+       --without-pam
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+MONIT_CONF_OPT += --with-ssl
+MONIT_DEPENDENCIES += openssl
+else
+MONIT_CONF_OPT += --without-ssl
+endif
+
+ifeq ($(BR2_LARGEFILE),y)
+MONIT_CONF_OPT += --with-largefiles
+else
+MONIT_CONF_OPT += --without-largefiles
+endif
+
+$(eval $(call AUTOTARGETS))