nmap: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 25 Feb 2013 04:39:51 +0000 (04:39 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 25 Feb 2013 19:34:08 +0000 (20:34 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/nmap/Config.in [new file with mode: 0644]
package/nmap/nmap.mk [new file with mode: 0644]

index 882d3c0e0f0a535c6f9fd0d1e6a116faca983723..e96b58fce8f94c928d7a55d7a8c1a4969dd2364c 100644 (file)
@@ -677,6 +677,7 @@ source "package/netsnmp/Config.in"
 source "package/netstat-nat/Config.in"
 source "package/network-manager/Config.in"
 source "package/nfacct/Config.in"
+source "package/nmap/Config.in"
 source "package/noip/Config.in"
 source "package/ngircd/Config.in"
 source "package/ngrep/Config.in"
diff --git a/package/nmap/Config.in b/package/nmap/Config.in
new file mode 100644 (file)
index 0000000..be1be33
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_NMAP
+       bool "nmap"
+       depends on BR2_INET_IPV6
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_USE_MMU # fork()
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_LIBPCAP
+       select BR2_PACKAGE_PCRE
+       help
+         Nmap ("Network Mapper") is a free and open source (license)
+         utility for network discovery and security auditing.
+
+         http://nmap.org
+
+comment "nmap requires a toolchain with C++, IPV6 and thread support"
+       depends on !(BR2_INSTALL_LIBSTDCPP && BR2_INET_IPV6 && BR2_TOOLCHAIN_HAS_THREADS)
diff --git a/package/nmap/nmap.mk b/package/nmap/nmap.mk
new file mode 100644 (file)
index 0000000..a5b085d
--- /dev/null
@@ -0,0 +1,24 @@
+#############################################################
+#
+# nmap
+#
+#############################################################
+
+NMAP_VERSION = 6.01
+NMAP_SITE = http://nmap.org/dist
+NMAP_SOURCE = nmap-$(NMAP_VERSION).tar.bz2
+NMAP_DEPENDENCIES = libpcap pcre
+NMAP_CONF_OPT = --without-liblua --without-zenmap \
+       --with-libdnet=included --with-liblinear=included \
+       --with-libpcre="$(STAGING_DIR)/usr"
+NMAP_LICENSE = GPLv2
+NMAP_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+NMAP_CONF_OPT += --with-openssl="$(STAGING_DIR)/usr"
+NMAP_DEPENDENCIES += openssl
+else
+NMAP_CONF_OPT += --without-openssl
+endif
+
+$(eval $(autotools-package))