tcl: remove strip command
authorRichard Genoud <richard.genoud@gmail.com>
Mon, 24 Jun 2013 08:40:53 +0000 (10:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 28 Jul 2013 14:19:58 +0000 (16:19 +0200)
Stripping is done at the end of the buildroot process, for all files at
once.
There's no need to do it here.
(Suggested by Thomas Petazzoni)

Signed-off-by: Richard Genoud <richard.genoud@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tcl/tcl.mk

index 7c08ee6469001a4c4d51efdbb2cd867dd40dcb40..564d5bca80d0fa26b4937503c30fa56d88ec8f7c 100644 (file)
@@ -22,11 +22,6 @@ HOST_TCL_CONF_OPT = \
                --disable-langinfo \
                --disable-framework
 
-define TCL_POST_INSTALL_CLEANUP
-       -$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libtcl8.4.so
-endef
-TCL_POST_INSTALL_TARGET_HOOKS += TCL_POST_INSTALL_CLEANUP
-
 ifeq ($(BR2_PACKAGE_TCL_DEL_ENCODINGS),y)
 define TCL_REMOVE_ENCODINGS
        rm -rf $(TARGET_DIR)/usr/lib/tcl$(TCL_VERSION_MAJOR)/encoding/*