package/nss-pam-ldapd: Do not mark .service file executable
authorAndrey Smirnov <andrew.smirnov@gmail.com>
Thu, 24 Aug 2017 21:41:52 +0000 (14:41 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 25 Aug 2017 14:09:58 +0000 (16:09 +0200)
Do not mark .service file executable, otherwise systemd
will give us a warning about it.

Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nss-pam-ldapd/nss-pam-ldapd.mk

index 1c4f73521a80e0fe82541a09c41f81bebd9dea77..3eddb5e2a1ff5afa1f80d8ff9b94b46c38949cf8 100644 (file)
@@ -27,7 +27,7 @@ NSS_PAM_LDAPD_CONF_OPTS += --disable-pam
 endif
 
 define NSS_PAM_LDAPD_INSTALL_INIT_SYSTEMD
-       $(INSTALL) -m 755 -D package/nss-pam-ldapd/nslcd.service \
+       $(INSTALL) -m 644 -D package/nss-pam-ldapd/nslcd.service \
                $(TARGET_DIR)/usr/lib/systemd/system/nslcd.service
        mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
        ln -fs ../../../../usr/lib/systemd/system/nslcd.service \