do not build valgrind for non-i386
authorEric Andersen <andersen@codepoet.org>
Sat, 1 Nov 2003 05:59:43 +0000 (05:59 -0000)
committerEric Andersen <andersen@codepoet.org>
Sat, 1 Nov 2003 05:59:43 +0000 (05:59 -0000)
make/valgrind.mk

index c7d89261c28408e32cf7435be52595dfff3cbef8..924d2116215d5b3838a3a33c324b428c6d4d272e 100644 (file)
@@ -72,7 +72,11 @@ $(TARGET_DIR)/usr/bin/valgrind: $(VALGRIND_DIR)/coregrind/valgrind.so
        #cp $(VALGRIND_DIR)/woody.supp $(TARGET_DIR)/usr/lib/valgrind/
        touch -c $(TARGET_DIR)/usr/bin/valgrind
 
+ifeq ($(ARCH),i386)
 valgrind: $(TARGET_DIR)/usr/bin/valgrind
+else
+valgrind:
+endif
 
 valgrind-clean: 
        $(MAKE) -C $(VALGRIND_DIR) clean