package/aubio: add libsndfile optional dependency
authorRomain Naour <romain.naour@gmail.com>
Sat, 3 Dec 2016 12:17:35 +0000 (13:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Dec 2016 15:22:08 +0000 (16:22 +0100)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/aubio/aubio.mk

index aa4ddd0fcedd1a91481231350bb529d07538b71e..e1694ab64dbe60b819e38e1c0931225be4a5d417 100644 (file)
@@ -16,9 +16,15 @@ AUBIO_CONF_OPTS = \
        --disable-atlas \
        --disable-samplerate \
        --disable-avcodec \
-       --disable-sndfile \
        --disable-jack \
        --disable-fftw3 \
        --disable-fftw3f
 
+ifeq ($(BR2_PACKAGE_LIBSNDFILE),y)
+AUBIO_DEPENDENCIES += libsndfile
+AUBIO_CONF_OPTS += --enable-sndfile
+else
+AUBIO_CONF_OPTS += --disable-sndfile
+endif
+
 $(eval $(waf-package))