boot/xloader: remove package
authorMatt Weber <matthew.weber@rockwellcollins.com>
Thu, 20 Sep 2018 21:54:24 +0000 (16:54 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 26 Oct 2018 14:59:05 +0000 (16:59 +0200)
U-boot has provided SPL support as a viable replacement for the
2nd stage bootloader on TI platforms.  The X-loader project
hasn't had a commit in the log since 12-05-2011.
(https://gitorious.org/x-loader/x-loader)

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
boot/Config.in
boot/xloader/Config.in [deleted file]
boot/xloader/xloader.mk [deleted file]

index bd236b2083fc6543e1f30b5aa672a851d7029a3a..c3df37ddd9cb8a0abdc23ea12330067525fdc8d3 100644 (file)
@@ -145,6 +145,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2018.11"
 
+config BR2_TARGET_XLOADER
+       bool "xloader has been removed"
+       select BR2_LEGACY
+       help
+         The package has been removed as u-boot SPL provides
+         similar functionality
+
 config BR2_PACKAGE_TIDSP_BINARIES
        bool "tidsp-binaries package removed"
        select BR2_LEGACY
index 945168bf37dc9100ece197d14f4ee57f1f107f9b..8e0c8e5df49a26c31bee5c25a4b7dd7dbd7a3b1a 100644 (file)
@@ -19,6 +19,5 @@ source "boot/syslinux/Config.in"
 source "boot/ts4800-mbrboot/Config.in"
 source "boot/uboot/Config.in"
 source "boot/vexpress-firmware/Config.in"
-source "boot/xloader/Config.in"
 
 endmenu
diff --git a/boot/xloader/Config.in b/boot/xloader/Config.in
deleted file mode 100644 (file)
index f687b89..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-config BR2_TARGET_XLOADER
-       bool "X-loader"
-       depends on BR2_cortex_a8 || BR2_cortex_a9
-       help
-         The x-loader bootloader. It is mainly used on OMAP-based
-         platforms.
-
-         http://omappedia.org/wiki/Linux_OMAP_Kernel_Main
-
-if BR2_TARGET_XLOADER
-config BR2_TARGET_XLOADER_BOARDNAME
-       string "x-loader board name"
-       help
-         One of x-loader supported boards to be built.
-         This will be suffixed with _config to meet x-loader
-         standard naming.
-endif
diff --git a/boot/xloader/xloader.mk b/boot/xloader/xloader.mk
deleted file mode 100644 (file)
index 7e0b286..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-################################################################################
-#
-# x-loader
-#
-################################################################################
-
-XLOADER_VERSION = 6f3a26101303051e0f91b6213735b68ce804e94e
-XLOADER_SITE = git://gitorious.org/x-loader/x-loader.git
-XLOADER_BOARD_NAME = $(call qstrip,$(BR2_TARGET_XLOADER_BOARDNAME))
-
-XLOADER_LICENSE = GPL-2.0+
-XLOADER_LICENSE_FILES = README
-
-XLOADER_INSTALL_IMAGES = YES
-
-define XLOADER_BUILD_CMDS
-       $(MAKE) CROSS_COMPILE="$(TARGET_CROSS)" -C $(@D) $(XLOADER_BOARD_NAME)_config
-       $(MAKE) CROSS_COMPILE="$(TARGET_CROSS)" -C $(@D) all
-       $(MAKE) CROSS_COMPILE="$(TARGET_CROSS)" -C $(@D) ift
-endef
-
-define XLOADER_INSTALL_IMAGES_CMDS
-       $(INSTALL) -D -m 0755 $(@D)/MLO $(BINARIES_DIR)/
-endef
-
-$(eval $(generic-package))
-
-ifeq ($(BR2_TARGET_XLOADER)$(BR_BUILDING),yy)
-ifeq ($(XLOADER_BOARD_NAME),)
-$(error NO x-loader board name set. Check your BR2_BOOT_XLOADER_BOARDNAME setting)
-endif
-endif