Patch from Volmat Alain adding SH3/SH3EB SH4EB support
authorEric Andersen <andersen@codepoet.org>
Sat, 11 Dec 2004 09:56:58 +0000 (09:56 -0000)
committerEric Andersen <andersen@codepoet.org>
Sat, 11 Dec 2004 09:56:58 +0000 (09:56 -0000)
Config.in
toolchain/kernel-headers/kernel-headers.mk
toolchain/uClibc/uclibc.mk

index df5607f92b1767e74cc7d41375835e6588843bdb..6d702a5a89594d8315df65e8d5418e84a266d781 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -36,9 +36,18 @@ config BR2_mipsel
 config BR2_powerpc
        bool "powerpc"
 
-config BR2_sh
+config BR2_sh3
+       bool "sh3"
+
+config BR2_sh3eb
+       bool "sh3eb"
+
+config BR2_sh4
        bool "sh4"
 
+config BR2_sh4eb
+       bool "sh4eb"
+
 config BR2_sparc
        bool "sparc"
 
@@ -54,7 +63,10 @@ config BR2_ARCH
        default "mips"    if BR2_mips
        default "mipsel"  if BR2_mipsel
        default "powerpc" if BR2_powerpc
-       default "sh4"     if BR2_sh
+       default "sh3"     if BR2_sh3
+       default "sh3eb"   if BR2_sh3eb
+       default "sh4"     if BR2_sh4
+       default "sh4eb"   if BR2_sh4eb
        default "sparc"   if BR2_sparc
 
 
index 0e77c4815a00427b75626f4f1ae1af2b7f3aa41c..f5640a472135ef3fc0156f60d30d7860bee85d08 100644 (file)
@@ -107,10 +107,22 @@ $(LINUX_HEADERS_DIR)/.configured: $(LINUX_HEADERS_DIR)/.patched
             ln -fs arch-ebsa285 arch; fi); \
        elif [ "$(ARCH)" = "cris" ];then \
            (cd $(LINUX_HEADERS_DIR)/include; ln -fs asm-cris asm;) \
+       elif [ "$(ARCH)" = "sh3" ];then \
+           (cd $(LINUX_HEADERS_DIR)/include; ln -fs asm-sh asm; \
+            cd asm; \
+            ln -s cpu-sh3 cpu) \
+       elif [ "$(ARCH)" = "sh3eb" ];then \
+           (cd $(LINUX_HEADERS_DIR)/include; ln -fs asm-sh asm; \
+            cd asm; \
+            ln -s cpu-sh3 cpu) \
        elif [ "$(ARCH)" = "sh4" ];then \
            (cd $(LINUX_HEADERS_DIR)/include; ln -fs asm-sh asm; \
             cd asm; \
             ln -s cpu-sh4 cpu) \
+       elif [ "$(ARCH)" = "sh4eb" ];then \
+           (cd $(LINUX_HEADERS_DIR)/include; ln -fs asm-sh asm; \
+            cd asm; \
+            ln -s cpu-sh4 cpu) \
        else \
            (cd $(LINUX_HEADERS_DIR)/include; ln -fs asm-$(ARCH)$(NOMMU) asm;) \
        fi
index 256a04282dd2ead6188f4725907ee8e3fbe8fb5e..bff50fd5b070959ca00369a38d4898216016ad81 100644 (file)
@@ -26,7 +26,7 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
                -e 's/ppc/powerpc/g' \
                -e 's/v850.*/v850/g' \
                -e 's/sh64/sh/' \
-               -e 's/sh[234]/sh/' \
+               -e 's/sh[234].*/sh/' \
                -e 's/mips.*/mips/' \
                -e 's/mipsel.*/mips/' \
                -e 's/cris.*/cris/' \