projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ae18c6b
)
package/tini: install docker-init symlink
author
Christian Stewart
<christian@paral.in>
Wed, 23 Dec 2020 03:35:01 +0000
(11:35 +0800)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Thu, 31 Dec 2020 13:45:11 +0000
(14:45 +0100)
This removes the warning that docker can't find docker-init in PATH.
Signed-off-by: Christian Stewart <christian@paral.in>
Signed-off-by: Tian Yuanhao <tianyuanhao@aliyun.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/tini/tini.mk
patch
|
blob
|
history
diff --git
a/package/tini/tini.mk
b/package/tini/tini.mk
index 157477f8dff4b2483a07310be09641e69951c1a9..af4a3bcb5e37938f130209e2185b970deedf4a01 100644
(file)
--- a/
package/tini/tini.mk
+++ b/
package/tini/tini.mk
@@
-30,6
+30,7
@@
endef
define TINI_INSTALL_TARGET_CMDS
$(INSTALL) -D -m 0755 $(@D)/bin/tini $(TARGET_DIR)/usr/bin/tini
+ ln -sf tini $(TARGET_DIR)/usr/bin/docker-init
endef
# Tini's CMakeLists.txt is not suitable for Buildroot.