qt: fix build with external toolchain
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 Jul 2009 09:54:35 +0000 (11:54 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 Jul 2009 09:54:35 +0000 (11:54 +0200)
Set QMAKE_LFLAGS so that at link time --sysroot is passed to the
linker, and Qt finds the external libraries. This fixes Qt build when
zlib or other libraries are external, instead of using Qt's internal
copy.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt/qt.mk

index e07457e4cb9c2c3817ea0d2fc91ef1e1394a4e11..ea59b07641c728802f5bba65e39f6a644a2fab4b 100644 (file)
@@ -448,6 +448,7 @@ endif
        $(call QT_QMAKE_SET,STRIP,$(TARGET_STRIP))
        $(call QT_QMAKE_SET,CFLAGS,$(TARGET_CFLAGS))
        $(call QT_QMAKE_SET,CXXFLAGS,$(TARGET_CXXFLAGS))
+       $(call QT_QMAKE_SET,LFLAGS,$(TARGET_LDFLAGS))
        -[ -f $(QT_QCONFIG_FILE) ] && cp $(QT_QCONFIG_FILE) \
                $(QT_TARGET_DIR)/$(QT_QCONFIG_FILE_LOCATION)
 # Qt doesn't use PKG_CONFIG, it searches for pkg-config with 'which'.