buildroot: support out-of-tree builds
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 31 Aug 2008 20:23:47 +0000 (20:23 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 31 Aug 2008 20:23:47 +0000 (20:23 -0000)
Add support and documentation for out-of-tree builds with syntax
like the Linux kernel (make O=<dir>).

docs/buildroot.html
project/Makefile.in

index 6e20d0419900c4acbb5cf95f7221e1f1d5befecc..89c59701b676d189d581585b66b3a8992bfb5dc3 100644 (file)
     <p>You can now disconnect or copy the content of your <code>dl</code> 
     directory to the build-host. </p>
 
+    <h3><a name="building_out_of_tree" id="building_out_of_tree"></a>
+    Building out-of-tree</h3>
+
+    <p>Buildroot supports building out of tree with a syntax similar
+    to the Linux kernel. To use it, add O=&lt;directory&gt; to the
+    make command line, E.G.:</p>
+
+<pre>
+ $ make O=/tmp/build
+</pre>
+
+    <p>And all the output files will be located under
+    <code>/tmp/build</code>.</p>
+
     <h3><a name="environment_variables" id="environment_variables"></a>
     Environment variables</h3>
 
index c4188505ba7738dacceee6df3b092ef9b3cee132..034b1fa6c9d89d0da076711349c13dd52c3167ee 100644 (file)
@@ -25,7 +25,14 @@ TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
 #")
 
 
+# Buildroot supports building out of tree similarly to the Linux kernel.
+# To use, add O= to the make command line (make O=/tmp/build)
 BASE_DIR:=$(shell pwd)
+ifdef O
+ifeq ("$(origin O)", "command line")
+BASE_DIR := $(O)
+endif
+endif
 
 TOPDIR_PREFIX:=$(strip $(subst ",, $(BR2_TOPDIR_PREFIX)))_
 #"))