grep: make locale handling less verbose
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 23 Jul 2008 12:08:53 +0000 (12:08 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 23 Jul 2008 12:08:53 +0000 (12:08 -0000)
As suggested by Bernhard.

package/grep/grep.mk

index 6b0a65933280759a957ca66946d9e00034e2d083..a1b9d12cc6f7be946f6b3687838b5285f75e97a6 100644 (file)
@@ -11,10 +11,6 @@ GNUGREP_CAT:=$(ZCAT)
 GNUGREP_BINARY:=src/grep
 GNUGREP_TARGET_BINARY:=bin/grep
 
-ifeq ($(BR2_ENABLE_LOCALE),y)
-GNUGREP_EXTRA_DEPS:=gettext libintl
-endif
-
 $(DL_DIR)/$(GNUGREP_SOURCE):
         $(WGET) -P $(DL_DIR) $(GNUGREP_SITE)/$(GNUGREP_SOURCE)
 
@@ -54,8 +50,9 @@ $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY): $(GNUGREP_DIR)/$(GNUGREP_BINARY)
        done
        $(STRIPCMD) $(STRIP_STRIP_ALL) $@
 
-grep: uclibc $(GNUGREP_EXTRA_DEPS) $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY)
-
+grep: uclibc $(if $(BR2_ENABLE_LOCALE),gettext libintl) \
+        $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY)
+       echo deps: $^
 grep-clean:
        rm -f $(addprefix $(TARGET_DIR)/bin/,egrep fgrep grep)
        -$(MAKE) -C $(GNUGREP_DIR) clean