Revert "qt: add QT_COORD_TYPE to double option"
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 5 May 2015 15:06:35 +0000 (17:06 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 5 May 2015 15:08:46 +0000 (17:08 +0200)
This reverts commit 7619aba496208102e098e24454371b9513ec2f90.

This change causes a number of build issues with poppler / pinentry /
python-pyqt and Qt itself on various architectures, so lets revert it for
now and rework it for the 2015.08 cycle.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt/Config.in
package/qt/qt.mk

index 83fdeec812bbd3d717ea7726fb4b92d1ed38f9d4..43f5a0fc7c0d4b5f5eadb2578870e177085ffc87 100644 (file)
@@ -120,16 +120,6 @@ config BR2_PACKAGE_QT_CONFIG_FILE
          This option allows to set the path of such a configuration
          file, which Buildroot will give to Qt at compile time.
 
-config BR2_PACKAGE_QT_QT_COORD_TYPE_DOUBLE
-       bool "QT_COORD_TYPE to double"
-       help
-         Set QT_COORD_TYPE to double. On ARM-based platforms, qreal
-         is a typedef for float for performance reasons, but for
-         QT_COORD_TYPE, some people may want to use a double type
-         anyway for precision.
-
-         If unsure say n.
-
 config BR2_PACKAGE_QT_QT3SUPPORT
        bool "Compatibility with Qt3"
        depends on BR2_PACKAGE_QT_GUI_MODULE
index 919137b2a259db452abeb38dedea8b8ecfa26c94..d1615ae0bfebb8f9b3bd5c3dacfe11caa5e3b112 100644 (file)
@@ -46,11 +46,6 @@ QT_CFLAGS += -marm
 QT_CXXFLAGS += -marm
 endif
 
-ifeq ($(BR2_PACKAGE_QT_QT_COORD_TYPE_DOUBLE),y)
-QT_CFLAGS += -DQT_COORD_TYPE=double
-QT_CXXFLAGS += -DQT_COORD_TYPE=double
-endif
-
 ifeq ($(BR2_PACKAGE_QT_QT3SUPPORT),y)
 QT_CONFIGURE_OPTS += -qt3support
 else