ti-uim: Add new package
authorAlexandre Belloni <alexandre.belloni@free-electrons.com>
Sun, 8 Dec 2013 11:30:17 +0000 (12:30 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 16 Dec 2013 21:53:44 +0000 (22:53 +0100)
[Peter: wrap help text, use full git hash, fix file header, drop license file]
Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/ti-uim/Config.in [new file with mode: 0644]
package/ti-uim/ti-uim.mk [new file with mode: 0644]

index 78a9e1605708e9f5feeb1b6e00fedbde1a1fef69..3685807fb87b40c40d40d6121ec7d520926ed6c9 100644 (file)
@@ -330,6 +330,7 @@ source "package/sunxi-mali/Config.in"
 source "package/sunxi-mali-prop/Config.in"
 source "package/sysstat/Config.in"
 source "package/ti-gfx/Config.in"
+source "package/ti-uim/Config.in"
 source "package/ti-utils/Config.in"
 source "package/uboot-tools/Config.in"
 source "package/udev/Config.in"
diff --git a/package/ti-uim/Config.in b/package/ti-uim/Config.in
new file mode 100644 (file)
index 0000000..451aad1
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_TI_UIM
+       bool "ti-uim"
+       help
+         User Mode Initialization Manager for TI wl12xx connectivity
+         chip shared transport drivers. This daemon is needed to get
+         the btwilink driver to work.
+
+         http://omappedia.org/wiki/Device_Driver_Interface_of_WiLink_Solution
diff --git a/package/ti-uim/ti-uim.mk b/package/ti-uim/ti-uim.mk
new file mode 100644 (file)
index 0000000..b498180
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# ti-uim
+#
+################################################################################
+
+TI_UIM_VERSION = c73894456df5def97111cb33d2106b684b8b7959
+TI_UIM_SITE = git://gitorious.org/uim/uim.git
+TI_UIM_LICENSE = GPLv2+
+
+define TI_UIM_BUILD_CMDS
+       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+endef
+
+define TI_UIM_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/uim \
+               $(TARGET_DIR)/usr/sbin/uim
+endef
+
+$(eval $(generic-package))