Remove the spider feature
authorMaxime Petazzoni <maxime.petazzoni@bulix.org>
Thu, 2 Sep 2010 10:09:44 +0000 (12:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 13 Sep 2010 06:17:46 +0000 (08:17 +0200)
In preparation for the re-work of the DOWNLOAD helper to support
multiple download methods and protocols, the spider feature used with
wget is removed for now until it is re-implemented on top of the new
download methods.

Signed-off-by: Maxime Petazzoni <maxime.petazzoni@bulix.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile
package/Makefile.package.in
package/mpfr/mpfr.mk

index 1ab446d8ba3ab20c18f74acb7eb0b99488c8314f..59a0e23034e34bf34b8c5422cd7bb1a9c3b8c787 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -244,7 +244,7 @@ ifeq ($(ARCH),xtensa)
 ARCH:=$(ARCH)_$(call qstrip,$(BR2_xtensa_core_name))
 endif
 
-WGET:=$(call qstrip,$(BR2_WGET)) $(SPIDER) $(QUIET)
+WGET:=$(call qstrip,$(BR2_WGET)) $(QUIET)
 SVN_CO:=$(call qstrip,$(BR2_SVN_CO)) $(QUIET)
 SVN_UP:=$(call qstrip,$(BR2_SVN_UP)) $(QUIET)
 BZR_CO:=$(call qstrip,$(BR2_BZR_CO)) $(QUIET)
@@ -437,11 +437,10 @@ endif
 source: $(TARGETS_SOURCE) $(HOST_SOURCE)
 
 _source-check:
-       $(MAKE) $(EXTRAMAKEARGS) SPIDER=--spider source
+       @echo "TODO $@"
 
 external-deps:
-       @$(MAKE) -Bs BR2_WGET=$(TOPDIR)/toolchain/wget-show-external-deps.sh \
-               $(EXTRAMAKEARGS) SPIDER=--spider source
+       @echo "TODO $@"
 
 show-targets:
        @echo $(TARGETS)
index d76b7913d2dc403a0a923a5fcad8b34e5745728f..ba0fd8433f94d4c37d4bd40526f272413c8c0295 100644 (file)
@@ -81,16 +81,11 @@ TERM_RESET := $(shell tput rmso)
 # $(call DOWNLOAD,$(FOO_SITE),$(FOO_SOURCE))
 ################################################################################
 
-# support make source-check/external-deps
-ifneq ($(SPIDER),)
-DOWNLOAD=$(WGET) -P $(DL_DIR) $(1)/$(2)
-else
 define DOWNLOAD
        $(Q)test -e $(DL_DIR)/$(2) || \
        for site in $(call qstrip,$(BR2_PRIMARY_SITE)) $(1) $(call qstrip,$(BR2_BACKUP_SITE)); \
        do $(WGET) -P $(DL_DIR) $$site/$(2) && exit; done
 endef
-endif
 
 # Utility programs used to build packages
 TAR ?= tar
@@ -117,19 +112,14 @@ endef
 
 # Retrieve the archive
 $(BUILD_DIR)/%/.stamp_downloaded:
-# support make source-check/external-deps
-ifeq ($(SPIDER),)
 # Only show the download message if it isn't already downloaded
        $(Q)(test -e $(DL_DIR)/$($(PKG)_SOURCE) && \
                (test -z $($(PKG)_PATCH) || test -e $(DL_DIR)$($(PKG)_PATCH))) || \
                $(call MESSAGE,"Downloading")
-endif
        $(call DOWNLOAD,$($(PKG)_SITE),$($(PKG)_SOURCE))
        $(if $($(PKG)_PATCH),$(call DOWNLOAD,$($(PKG)_SITE),$($(PKG)_PATCH)))
-ifeq ($(SPIDER),)
        $(Q)mkdir -p $(@D)
        $(Q)touch $@
-endif
 
 # Unpack the archive
 $(BUILD_DIR)/%/.stamp_extracted:
index a7834dd9bc314ca6217e588d8b513d03da522118..b7b80a5a4ada9072d73e55d2e6f702721cab7349 100644 (file)
@@ -21,10 +21,8 @@ MPFR_PATCH_SOURCE:=$(DL_DIR)/$(MPFR_PATCH_FILE)
 
 $(MPFR_PATCH_SOURCE):
        $(call DOWNLOAD,$(MPFR_SITE),$(MPFR_PATCH))
-ifeq ($(SPIDER),) # this breaks source-check/external-deps
        mv $(DL_DIR)/$(MPFR_PATCH) $@
 endif
-endif
 
 $(DL_DIR)/$(MPFR_SOURCE):
         $(call DOWNLOAD,$(MPFR_SITE),$(MPFR_SOURCE))