package/libsecret: enable gobject-introspection support
authorAdam Duskett <Aduskett@gmail.com>
Wed, 1 Apr 2020 00:21:23 +0000 (17:21 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 20:35:01 +0000 (22:35 +0200)
If gobject-introspection is selected, add the gobject-introspection package to
the dependency list and set the conf opt --enable-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libsecret/libsecret.mk

index b48d2e70867fdfc64119f01e87b29b621b1d872f..f87df47097b8599fd5f5f47628b326797cb45632 100644 (file)
@@ -15,11 +15,17 @@ LIBSECRET_CONF_OPTS = \
        --disable-manpages \
        --disable-strict \
        --disable-coverage \
-       --enable-introspection=no \
        --enable-vala=no
 LIBSECRET_LICENSE = LGPL-2.1+
 LIBSECRET_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+LIBSECRET_CONF_OPTS += --enable-introspection=yes
+LIBSECRET_DEPENDENCIES += gobject-introspection
+else
+LIBSECRET_CONF_OPTS += --enable-introspection=no
+endif
+
 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
 LIBSECRET_DEPENDENCIES += libgcrypt
 LIBSECRET_CONF_OPTS += --enable-gcrypt \