package/vlc: add optional dependency to wayland
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:34 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 11:37:00 +0000 (13:37 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index 3dbaac17570b6dc34475e9bb5a14b5e9066a4937..53a2b6163356718abacc6ad457d5dd60abf6c372 100644 (file)
@@ -84,7 +84,6 @@ VLC_CONF_OPTS += \
        --disable-vdpau \
        --disable-vsxu \
        --disable-wasapi \
-       --disable-wayland \
        --disable-x262 \
        --disable-zvbi \
        --enable-run-as-root
@@ -529,6 +528,13 @@ else
 VLC_CONF_OPTS += --disable-udev
 endif
 
+ifeq ($(BR2_PACKAGE_WAYLAND),y)
+VLC_CONF_OPTS += --enable-wayland
+VLC_DEPENDENCIES += wayland
+else
+VLC_CONF_OPTS += --disable-wayland
+endif
+
 ifeq ($(BR2_PACKAGE_X264),y)
 VLC_CONF_OPTS += --enable-x264
 VLC_DEPENDENCIES += x264