squashfs: Add lz4 hc compression
authorMatthias Weisser <m.weisser.m@gmail.com>
Tue, 11 Aug 2015 07:58:21 +0000 (09:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 4 Oct 2015 16:35:40 +0000 (18:35 +0200)
lz4 offers a high compression mode. A minimalistic file system shrinks by about 15%.

[Peter: Unconditionally use hc mode for lz4 instead of introducing another option]
Signed-off-by: Matthias Weisser <m.weisser.m@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
fs/squashfs/squashfs.mk

index 446906f10c77be1708c02b1389fe5524dc792876..a71d9cc57b5d8071094d73f22a1c04b145ba1f01 100644 (file)
@@ -7,7 +7,7 @@
 ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
 
 ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZ4),y)
-ROOTFS_SQUASHFS_ARGS += -comp lz4
+ROOTFS_SQUASHFS_ARGS += -comp lz4 -Xhc
 else
 ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZO),y)
 ROOTFS_SQUASHFS_ARGS += -comp lzo