package/lua-lunitx: new package
authorFrancois Perrad <fperrad@gmail.com>
Wed, 3 Apr 2019 13:06:08 +0000 (15:06 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 3 Apr 2019 19:35:35 +0000 (21:35 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/Config.in
package/lua-lunitx/Config.in [new file with mode: 0644]
package/lua-lunitx/lua-lunitx.hash [new file with mode: 0644]
package/lua-lunitx/lua-lunitx.mk [new file with mode: 0644]

index db79b61971525d4a472ba3c4dcb3c43be8fd229b..287f3493be689608e040e57105371d414be4186f 100644 (file)
@@ -622,6 +622,7 @@ menu "Lua libraries/modules"
        source "package/lua-http/Config.in"
        source "package/lua-iconv/Config.in"
        source "package/lua-lpeg-patterns/Config.in"
+       source "package/lua-lunitx/Config.in"
        source "package/lua-markdown/Config.in"
        source "package/lua-messagepack/Config.in"
        source "package/lua-msgpack-native/Config.in"
diff --git a/package/lua-lunitx/Config.in b/package/lua-lunitx/Config.in
new file mode 100644 (file)
index 0000000..ea900e6
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LUA_LUNITX
+       bool "lua-lunitx"
+       help
+         Lunitx is a unit testing framework for lua, written in lua.
+
+         https://github.com/dcurrie/lunit
diff --git a/package/lua-lunitx/lua-lunitx.hash b/package/lua-lunitx/lua-lunitx.hash
new file mode 100644 (file)
index 0000000..b97b93f
--- /dev/null
@@ -0,0 +1,3 @@
+# computed by luarocks/buildroot
+sha256 2299facf4977f9b663e1ad402098139116a87a693c3df66e1f6b89e2cf47646f  lunitx-0.8-1.src.rock
+sha256 3fcfcd6010d73bc2b22505b6a91779022a82661809a3e4e0a0bdd7b3463def8f  lunit/LICENSE
diff --git a/package/lua-lunitx/lua-lunitx.mk b/package/lua-lunitx/lua-lunitx.mk
new file mode 100644 (file)
index 0000000..e12cf07
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# lua-lunitx
+#
+################################################################################
+
+LUA_LUNITX_VERSION = 0.8-1
+LUA_LUNITX_NAME_UPSTREAM = lunitx
+LUA_LUNITX_SUBDIR = lunit
+LUA_LUNITX_LICENSE = MIT
+LUA_LUNITX_LICENSE_FILES = $(LUA_LUNITX_SUBDIR)/LICENSE
+
+$(eval $(luarocks-package))