squid: add gnutls support
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Mon, 6 Jul 2015 08:02:05 +0000 (10:02 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 6 Jul 2015 15:47:56 +0000 (17:47 +0200)
A new --without-gnutls option has been added to configure, so let's use
it in order to enable or disable gnutls support in squid.

Related:

  http://www.squid-cache.org/Versions/v3/3.5/squid-3.5.6-RELEASENOTES.html#ss4.1

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/squid/squid.mk

index 469fb1bb3af42a27996862efd98c6dd57d0d44ac..80235a4cecd34b2c88de3a706135660cd1179765 100644 (file)
@@ -62,6 +62,13 @@ SQUID_CONF_OPTS += --with-openssl
 SQUID_DEPENDENCIES += openssl
 endif
 
+ifeq ($(BR2_PACKAGE_GNUTLS),y)
+SQUID_CONF_OPTS += --with-gnutls
+SQUID_DEPENDENCIES += gnutls
+else
+SQUID_CONF_OPTS += --without-gnutls
+endif
+
 define SQUID_CLEANUP_TARGET
        rm -f $(addprefix $(TARGET_DIR)/usr/bin/, \
                RunCache RunAccel)