package/kodi: Add option for lirc support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 22 Jul 2015 20:30:27 +0000 (22:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 30 Jul 2015 07:29:23 +0000 (09:29 +0200)
https://github.com/xbmc/xbmc/commit/b641e1eea54b4b9ab7f1b95092ab0a755abc63be

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/Config.in
package/kodi/kodi.mk

index e8c9244391c6e69e8e05afd459e215b10c98f17c..8dd37942db179f5bcef7919bdfa1f2edba10d6ba 100644 (file)
@@ -164,6 +164,11 @@ config BR2_PACKAGE_KODI_LIBCEC
 comment "hdmi cec support needs udev /dev management and a toolchain w/ dynamic library"
        depends on BR2_STATIC_LIBS || !BR2_PACKAGE_HAS_UDEV
 
+config BR2_PACKAGE_KODI_LIRC
+       bool "lirc"
+       help
+         Enable lirc support
+
 config BR2_PACKAGE_KODI_LIBMICROHTTPD
        bool "web server"
        select BR2_PACKAGE_LIBMICROHTTPD
index e5304abf20ee1a0391a567042b18968c9d36f276..6399ff1d9204ace18eb9ece15cadf8b1734494a5 100644 (file)
@@ -186,6 +186,12 @@ else
 KODI_CONF_OPTS += --disable-libcec
 endif
 
+ifeq ($(BR2_PACKAGE_KODI_LIRC),y)
+KODI_CONF_OPTS += --enable-lirc
+else
+KODI_CONF_OPTS += --disable-lirc
+endif
+
 ifeq ($(BR2_PACKAGE_KODI_WAVPACK),y)
 KODI_DEPENDENCIES += wavpack
 endif