support/download: make sure the download folder is created
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Mon, 2 Apr 2018 13:09:27 +0000 (15:09 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Apr 2018 14:09:56 +0000 (16:09 +0200)
At the moment, it means that we make sure that BR2_DL_DIR is created, in
the future, it will make sure that BR2_DL_DIR/PKG_NAME/ is created.

[Peter: drop trailing / on mkdir]
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-download.mk

index 3f525ee5e4a35333752f933c8edd3e933337aac8..3f35661a161b5e3333e1721db494eb54422f5742 100644 (file)
@@ -88,6 +88,7 @@ endif
 endif
 
 define DOWNLOAD
+       $(Q)mkdir -p $($(PKG)_DL_DIR)
        $(Q)$(if $(filter bzr cvs hg svn,$($(PKG)_SITE_METHOD)),
                BR_NO_CHECK_HASH_FOR=$(notdir $(call qstrip,$(1)))) \
        $(EXTRA_ENV) $(DL_WRAPPER) \