glog: new package
authorRahul Bedarkar <rahul.bedarkar@imgtec.com>
Wed, 10 Jun 2015 05:50:49 +0000 (11:20 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 12 Jun 2015 20:05:34 +0000 (22:05 +0200)
Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
Reviewed-by: Abhimanyu Vishwakarma <abhimanyu.v@imgtec.com>
Reviewed-by: Marcin Nowakowski <marcin.nowakowski@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/glog/Config.in [new file with mode: 0644]
package/glog/glog.hash [new file with mode: 0644]
package/glog/glog.mk [new file with mode: 0644]

index 6810bd669cbb0e2e192f2c8225e0d51808d4c132..6dbc32d5d2029ccc360b632a809e49092c8e296e 100644 (file)
@@ -896,6 +896,7 @@ menu "JSON/XML"
 endmenu
 
 menu "Logging"
+       source "package/glog/Config.in"
        source "package/liblog4c-localtime/Config.in"
        source "package/liblogging/Config.in"
        source "package/log4cplus/Config.in"
diff --git a/package/glog/Config.in b/package/glog/Config.in
new file mode 100644 (file)
index 0000000..aed0a3e
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_GLOG
+       bool "glog"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       help
+         C++ implementation of the Google logging module
+
+         https://github.com/google/glog
+
+comment "glog needs a toolchain w/ C++, threads"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/glog/glog.hash b/package/glog/glog.hash
new file mode 100644 (file)
index 0000000..dad1543
--- /dev/null
@@ -0,0 +1,2 @@
+# No hash for v0.3.4, comes from the github-helper:
+none   xxx     glog-v0.3.4.tar.gz
diff --git a/package/glog/glog.mk b/package/glog/glog.mk
new file mode 100644 (file)
index 0000000..8a84094
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# glog
+#
+################################################################################
+
+GLOG_VERSION = v0.3.4
+GLOG_SITE = $(call github,google,glog,$(GLOG_VERSION))
+GLOG_INSTALL_STAGING = YES
+GLOG_LICENSE = BSD-3c
+GLOG_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_GFLAGS),y)
+GLOG_DEPENDENCIES = gflags
+endif
+
+$(eval $(autotools-package))