package/strongswan: install dev headers
authorMatt Weber <matthew.weber@rockwellcollins.com>
Thu, 20 Sep 2018 15:16:27 +0000 (10:16 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 20 Sep 2018 19:08:47 +0000 (21:08 +0200)
Adds '--with-dev-headers' configure option to install
development headers into staging.  The package provides
these headers to enable linking against pluggins.

Signed-off-by: Paresh Chaudhary <paresh.chaudhary@rockwellcollins.com>
Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/strongswan/strongswan.mk

index 5c597d572ae24b48fb6554971519575c4a80c9bb..632a742e9c4f8ad84e34c42a8cb579e10ecb298c 100644 (file)
@@ -10,6 +10,7 @@ STRONGSWAN_SITE = http://download.strongswan.org
 STRONGSWAN_LICENSE = GPL-2.0+
 STRONGSWAN_LICENSE_FILES = COPYING LICENSE
 STRONGSWAN_DEPENDENCIES = host-pkgconf
+STRONGSWAN_INSTALL_STAGING = YES
 STRONGSWAN_CONF_OPTS += \
        --without-lib-prefix \
        --enable-led \
@@ -36,7 +37,8 @@ STRONGSWAN_CONF_OPTS += \
        --enable-swanctl=$(if $(BR2_PACKAGE_STRONGSWAN_VICI),yes,no) \
        --with-ipseclibdir=/usr/lib \
        --with-plugindir=/usr/lib/ipsec/plugins \
-       --with-imcvdir=/usr/lib/ipsec/imcvs
+       --with-imcvdir=/usr/lib/ipsec/imcvs \
+       --with-dev-headers=/usr/include
 
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 STRONGSWAN_CONF_ENV += LIBS='-latomic'