package/dhcp: add host-gawk optional dependency
authorHeiko Thiery <heiko.thiery@gmail.com>
Fri, 7 May 2021 09:43:05 +0000 (11:43 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 20 May 2021 18:16:39 +0000 (20:16 +0200)
On hosts where gawk is not available, it is not possible to build the
package with server option (BR2_PACKAGE_DHCP_SERVER).
The build goes through without errors but the binaries are not created
and installed. The reason is that autotools cannot find gawk.

Fixes: Bug 13781
Reported-by: Kay Jeschonneck <kay.jeschonneck@airbus.com>
Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/dhcp/dhcp.mk

index 988c7792dc322f68654bbd0a565777a2849b001a..8d7157f357d393991fa7e2009b9c7ccf2639a871 100644 (file)
@@ -55,6 +55,7 @@ define DHCP_INSTALL_LIBS
 endef
 
 ifeq ($(BR2_PACKAGE_DHCP_SERVER),y)
+DHCP_DEPENDENCIES += host-gawk
 define DHCP_INSTALL_CTL_LIBS
        $(MAKE) -C $(@D)/dhcpctl install-exec DESTDIR=$(TARGET_DIR)
 endef